Windows Supported?

I am having issues getting started with Windows. On Windows 7, I saw that the USB driver was installed OK, but I don’t see a new COM port in Device Manager. On Windows 10, I do see a new USB device named “Cascadia WebUSA FPGA Programmer”. On either system Device Info shows “Waiting for connection…”. Anything I try results on the message “Error: WebUSA not supported”.


Sorry, make that WebUSB!

Which browser(s) and version(s) are you trying to use?

Also, what are the specific revision/patch levels of the Windows 7 and 10 installs you are using?

I saw one note from back in 2018 which suggested that older Windows 7 installs (those which weren’t updated to more recent OS patch levels) might not support WebUSB.

Windows 7 Home Premium SP1. Just updated to latest level this morning. Firefox Quantum 68.0.2 (64-bit). Up to date. Chrome says “No compatible devices found”. Version 76.0.3809.132 Official 64-bit. Up to date. I don’t see any new device of any sort when I plug the WebFPGA into my hub or laptop.

Windows 10: Those fine folks from Microsoft updated to the latest version of Win 10 yesterday and the laptop is unusable at the moment. I will try another Win 10 laptop later. I also have a Win 8.1 PC I will try.


Windows 8.1 works with Chrome, not Firefox. Firefox 68.0.2 reports > error: WebUSB not supported. I’ll revisit the other systems, but I’m good to go on at least one.


I was having the same difficulty, using Chrome browser on Windows 7 SP1. Device manager does not see Cascadia WebUSB FPGA, and it did not show up in the WebFPGA “Connect Device” device list.

Some experience with other non-standard USB devices (software defined radios) suggested that this might be a driver issue that could be corrected by installing the WinUSB driver for this device with Zadig ( When I ran zadig, after using the option to “List All Devices,” the Cascadia showed up in the devices list. I then installed WinUSB (v6.1.7600.16385) for that device. Installation completed successfully.

Now, when I run the WebFPGA IDE, the “Cascadia WebUSB FPGA Programmer” shows up in the device list, I can connect to it, and have successfully flashed the WF_blinky.v example.

The Cascadia WebUSB FPGA Programmer still does not show up anywhere in Windows 7 Device Manager.

As a side note, I hooked the board up to my Chromebook (a rather old, Acer C720 model), and connected to the Cascadia WebUSB FPGA Programmer with no trouble.

Hi all, I believe that the issue stems from missing drivers on the host OS. WebUSB communicates with a special OS USB driver. So, even if Chrome/Opera is completely up-to-date… if you are missing the USB driver, then it’s no beuno for WebUSB.

Windows 7 has popular USB drivers pre-installed by default (think FTDI). But I’m pretty sure it’s missing the generic WebUSB driver. Windows 10 has it now – and the Linux kernel has had it for a while.

The site @wwoofbu listed should work fine. I’ve previously used that program for installing drivers for Arduino boards.

The browser support for WebUSB is shown at

P.S. I also added this to the documentation category

I had the same issue.
Just a confirmation that updating the webUSB driver worked also fine for me on Win7.
Cascadia WebUSB FPGA is also visible in the device manager.
Thanks for the help