Trouble connecting Ubuntu VM

Hi - having trouble connecting to the device from Chrome, running from Ubuntu, within VirtualBox:
‘error unable to enumerate USB device list’

The webfpga is picked up in the virtual box usb settings.

Also, within Ubuntu the device appears to be recognized:

Trying to run chrome as admin (maybe this the issue?) but having trouble –

trying: ‘sudo google-chrome --no-sandbox --user-dir=’//home/test’
complains ‘need to configure your SUID sandbox correctly’

Can anyone point me in the right direction? Should it be possible to connect to the webfpga from a VM like this?


Hiya Scott,

I’ll try to replicate this issue today with VirtualBox. Mind telling me which version of Ubuntu you installed on your VM?

– Ryan

Hey actually,

Have you installed these udev rules?

– Ryan

I did miss the udev rule, sorry, new to Linux! Following the post, I made the file in: /etc/udev/rules.d

named 60-webfpga.rules, with:
SUBSYSTEM==“usb”, ATTR{idVendor}==“16d0”, ATTR{idProduct}==“0e6c”, TAG+=“uaccess”

and still get an error:

SecurityError: Failed to execute ‘requestDevice’ on ‘USB’: Must be handling a user gesture to show a permission request.
error: unable to enumerate USB device list

I did try the command to reload the udev rules without rebooting. Then I rebooted just in case, same result.

I am running Ubuntu-20.04.1-desktop-amd64.iso.

The webFPGA works under windows 10, blinky code runs great as advertised. However, I would like to be able to use a Linux environment for IceStorm etc as it seems these tools don’t play nice with Windows!

Any other suggestions? I’ll go back through the posts & documentation in case I missed any other details. Many thanks for your help!


Ah. So the good news is that the udev rules seem to have worked.

The error:
Must be handling a user gesture to show a permission request.

is Google Chrome telling you that it won’t allow the code to access your USB device until you click on the device on the pop-up menu. Try refreshing the website or clicking on the padlock icon on URL-navigation-bar to check if the pop-up has been blocked.


Strange - I hit the padlock and enable pop ups but still throws same error after refreshing the webpage. However, if I then hit connect device, the pop up comes up, I can select the device and it works!! Yay! Many thanks!!!

Next up… wondering if you can help with another issue trying to synthesize from the command line, will post that in a separate thread…

Thanks again, by the way, webFPGA is awesome, a great learning tool!